Nest Heatlink aansluiten op Danfoss AMZ 112 stadsverwarming oplossing


  • #1
Hello all,

Sorry for my English, I live in NL... need to learn a bit more Dutch... :-D

I had the same problem that is described here and I spent quite some time to solve it.

I had the normal honeywell simple device (this was after removing it).

To remove it is quite simple, remove the plastic around it and after push it down to remove this part.

The holes in the wall are in the same position as google nest, which makes it easier.


Initially I did only the setup of google nest and the heating was turned on all the time, after I tried to connect the red and blue to the nest 2 and 3 and the heating was always off.

I started to think about it and come up with a diagram to connect it, is working very well and I really would like to share it and eventually help someone else struggling with the same problem I had.

I have the old mode of the Danfoss AMZ 112, so my setup is based on that one, I cannot say anything about other models... I'm not a plumber but I did some studies in Electric Engineering (that helped I guess).

This was the initial wiring


Here is a picture of my valve


I have the google nest 3rd Generation

Here is a picture of how I setup my connection


I don't understand why google doesn't ship a wire to connect to the 220v.... they want to make things mode complicated for us!!!! This is required for the system to be powered.

The red from the valve connects to nothing (dont leave it free... just keep it connected to the same place)
The Blue connects to 24v
The Brown connect to 3
The Black connects to 2

The 24v need to be connected to the Blue wire of the DanFoss and to the 3 (together with the brown wire).

This is because the valve required 24v energy to act we need to feed it on the blue and brown.

Maybe there are other ways to use the valve in a better or more effective way, for me this worked.

Hope this helps someone else... not complicated I guess.

Enjoy 1619356350998.png
  • Informatief
Waarderingen: Klusidee ralf


  • #2
It worked perfectly for me, thanks a lot!



Je wachtwoord vergeten?
Nog niet geregistreerd? Registreer nu